Data not loading after login

Incident Report for Youth Opportunities

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 08, 2026 - 23:40 UTC

Identified

When a user signs in via Google or LinkedIn, they are briefly redirected away from our app to Google or LinkedIn's login page, then sent back. During this return journey, the app starts fetching data from the database before the sign-in process has fully completed. Our website then saves these empty results in a temporary cache, thinking it has already got the latest data.

We are working on a fix for this issue.
Posted Feb 08, 2026 - 23:05 UTC
This incident affects: Website (youthopportunities.co.uk).